Viewing & Analyzing Data in Lab

The Slam Stick Lab opens and plots recorded data for initial analysis. To open a recording file, go to File > Open and navigate to the location on your computer where the .IDE files are saved. 

In this Article


Plot Window

In the plot window the Lab will plot all sensor channels in one tab and open separate tabs per global sensor channel. 

Buffer Max and Min

The Slam Stick saves the minimum, maximum and mean of each “Buffer” of data that is written to disk. A “Buffer” is about 4,000 data points, so the frequency of these is directly proportional to the sampling rate. The Slam Stick Lab software enables the user to utilize the buffer information in two ways. Buffer data is also utilized to help illustrate the moving maximum and minimum acceleration level bands. The Slam Stick Lab does not plot every data point when zoomed out for efficiency, so when zoomed out of a dataset it can appear that the vibrations were less dense and/or less severe than in actuality. The Buffer Maximum and Minimum display can help visualize how the maximum and minimum acceleration levels are changing with time. This can be especially helpful when plotting data over a long time period.

When there are more buffers than the number of pixels on the screen, the Slam Stick Lab plots just the buffer maximum and minimums. This is done to enable faster drawing times and to provide a clear visualization on the acceleration data extremes.

Zooming

Zooming is achieved by simply clicking and dragging/drawing a rectangle with your mouse in the area you'd like to zoom. The image shown above, when zoomed in, will plot the data within the buffer max/mins (the dotted lines) as shown below.

There are also zoom buttons on the upper right for zooming in/out in the time domain ; and  the buttons in the upper left are for the amplitude range. The center button zooms to fit for that axis and there are keyboard shortcuts for this as well. Alt+0 will zoom to fit in the  y axis ; CTRL+0 will zoom to fit in the  x axis . CTRL+ALT+0 will zoom to fit in both directions.

Time Navigator & Display Range Markers

The top bar in the window (Time Navigator) shows the entire time of the recording with two blue triangles (Display Range Markers) indicating the time period being shown in the current plot.

Horizontal Scroll Bar

The bottom scroll bar will keep the same spacing between the display range markers but allow the user to finely scroll through the time domain.

Mouse Cursor Location & UTC Time

When the mouse is in the plot window the Slam Stick Lab will identify the x and y location of the cursor, and it will provide the UTC time that corresponds to that x location (time in seconds).

Legend

Right clicking on the legend will allow the user to change the legend location, change colors, and change the plot order (to plot a certain subchannel ahead/over another).


View Preferences

View Menu

In the plot window, the Lab will plot all sensor channels in one tab and open separate tabs per global sensor channel. 

The view menu also provides similar functionality as the shortcuts shown in the plot window. The main functionality of this menu is to create new plotting tabs and to disable or enable different sensor channels. Multiple channels can be displayed in one tab as long as they are the same units.

“Hollow” envelope drawing when enabled will show just the buffer max/min and white space in between; when disabled it will shade this region in. The trouble with this approach is that it can hide the other sensor channels’ data.

Preferences Menu

There are a number of user preferences which can be set in the Preferences window, accessible under the Edit menu. Many of these options are self-explanatory but some are explained below in the following subsections.

Data Options

These are only applicable for piezoelectric accelerometer data from the Slam Stick X. Data from this sensor requires some high pass filtering and the calibration applies a temperature correction. See the Mean Removal (High-Pass Filtering) and Bivariate References sections for more information.

Drawing Options

The user can opt between having one plot tab per sensor, per channel, or per sensor type. There are also some numerical variables for controlling how many samples are plotted on the screen to optimize efficiency.

Importing Options

The Slam Stick Lab can immediately begin plotting data when opening a file but the number of points that are loaded before initially plotting is user selectable. The higher the number, the longer it will take to initially plot; but the user will get a better picture of the recording than if just the first couple thousand samples were plotted.


Recording Properties

Once a recording has been loaded, Slam Stick Lab can display information on the recording file and on the device that generated the recording. To access this information click on Recording Properties under the File drop-down menu or use the keyboard shortcut Ctrl+I as shown below. The most useful tab in this window is the channel info tab which has max/min values for each channel and when they occurred. The sample rate is also shown along with the sensor part number.


Another useful tab is the one that lists the sensor part numbers used that generated the data.

Frequently one also must know when their unit was made, calibrated, what the serial number is, firmware revision etc. which is accessed from the Device Info tab.


Data Options

The Data menu allows the user to do some data manipulation as explained in the following couple sections. 

Mean Removal (High-Pass Filtering)

This is only relevant for the Slam Stick X; but users of the C and S may also use this feature in the Render plots option.

The piezoelectric accelerometer in the Slam Stick X has a DC bias that shifts with temperature change rate; and this dependency varied dramatically from unit-to-unit. Therefore it became very difficult to calibrate for and Midé instead uses a mean filtering to apply a simply high-pass filter to remove the DC component of the signal. The user can either remove the mean across the entire recording; or remove a rolling mean (the time interval is editable under the preferences tab); or disable mean removal to see the raw signal. For more on filtering, and for greater control of filtering,  read our article on filters.

Note

Mean removal is highly recommended for viewing data from the piezoelectric accelerometer. Remember that this type of accelerometer can’t measure low frequency or static accelerations; there will not be a 1g offset due to gravity. See our blog on accelerometer types for more information. Only users wishing to apply their own high-pass filter should opt to disable the mean removal.

Unit Conversion

A number of units are supported. For calculating altitude from pressure data, the defaults levels for temperature and pressure at sea level can be edited once you’ve made the initial conversion into feet or meters.

The equation for converting pressure to altitude is as follows (discussed in more length on our Pressure Altitude Calculator page):

where: Tb is the temperature at sea level (K), Pb is the pressure at sea level (Pa), Lb is the temperature lapse rate (-0.0065 K/m), g0 is the gravitational acceleration constant (9.807m/s2), M is the molor mass of Earth's air (0.02896 kg/mol), R is the universal gas constant (8.314 Nm/mol/K).  The temperature and pressure at sea level used in this calculation can be adjusted by configuring the unit conversion (available in the menu after initially converting to altitude.

Edit Calibration

This lets you edit the calibration coefficients for the data being plotted/analyzed. This will not change the raw data in the file itself, just how it appears in the plot window. See the  User Calibration Configuration for more information on these coefficients. 

Bivariate References

This is only applicable for the piezoelectric accelerometer in the Slam Stick X that has a temperature-dependent calibration coefficient (-0.3% per degree C). Disabling this temperature dependent calibration is useful for reducing computation time, especially when your recording is within a couple degrees of room temperature.

Display Warnings

Data recorded outside -20 to 80C will be shaded in to warn users of potential calibration error at these extremes.


Analysis

The Slam Stick Lab supports some analysis options which are available under the Data > Render drop down. The dialog box is very similar for the different analysis options. The user selects which channels to analyze in the top of the window and the time range for the analysis. Mean removal is then available regardless of the sensor you’re using; this is helpful for offering a simple means of filtering out low frequency data. For piezoelectric data, the temperature reference (bivariate reference) can be disabled to expedite analysis time.

Note

For advanced analysis the enDAQ Analyzer should be used. This analysis portal can feasibly "only" handle about 1 million data points before it can become too memory intensive and potentially crash.

Render Plots

This just provides a clean plot window that will plot all data points for the selected time range and channel(s). The main plot window will be selective with how many discrete points are actually plotted; but that is not the case in the render plots window. All data points are plotted.

Render FFT

Any waveform is actually just the sum of a series of simple sinusoids of different frequencies, amplitudes, and phases. A Fourier series is that series of sine waves; and we use Fourier analysis or spectrum analysis to deconstruct a signal into its individual sine wave components. The result is acceleration/vibration amplitude as a function of frequency, which lets us perform analysis in the frequency domain (or spectrum) to gain a deeper understanding of our vibration profile. Most vibration analysis will typically be done in the frequency domain. The FFT provides the means of calculating that frequency domain. For more information, visit our blog that covers FFTs, PSDs, and spectrograms.

Render PSD

Power spectral densities (PSD) are used to characterize random vibration signals. A PSD is computed by multiplying each frequency bin in an FFT by its complex conjugate which results in the real only spectrum of amplitude in g 2. The key aspect of a PSD which makes it more useful than a FFT for random vibration analysis is that this amplitude value is then normalized to the frequency bin width to get units of g2/Hz. By normalizing the result we reduce the dependency on the number of samples in the original acquisition. The area under the curve in a PSD represents the RMS vibration energy in that frequency range. This area can be calculated precisely by exporting the PSD into a CSV file, summing the data in the desired frequency range, and multiplying by the frequency bin width, or the space between adjacent frequencies. Slam Stick Lab filters the three lowest frequencies to 0 to remove the DC component. For more information, visit our blog that covers FFTs, PSDs, and spectrograms.

Slam Stick Lab can calculate the PSD in two ways, a full calculation or a windowed calculation. A full calculation will operate on the entire range with a single FFT and no windowing. A windowed operation will divide the signal into windows of exactly the selected size, throwing out any data that does not fit into a window. A Hanning window function is then applied to each window, the FFT is applied to the result, and the PSD is taken. A windowed PSD uses less computational power and memory, and results in cleaner looking data because it is an average of data sets. Note the windowed calculation may miss data at the end of a signal that does not fit into a window, and windowed and full calculations will result in different frequency bin widths. See our blog on windowing and frequency leakage for more information.

Spectrogram

A spectrogram takes a series of FFTs to provide an illustration on how the frequency content is changing with time. The user can select how many “slices” per second for the spectrogram. Each slice has a Hanning window applied to generate smoother data. For more information, visit our blog that covers FFTs, PSDs, and spectrograms.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.